Jump to content
EleTD.com
Sign in to follow this  
Australian

Not gaining gold

Recommended Posts

After spending the initial 250g, kills and interest after give 0 gold. The bounty numbers show on kill, but it doesn't appear on the hud (next to lumber/pure essence etc). This has happened twice now, both while playing solo in a custom lobby.

If it helps I was playing Chaos, Insane, All Pick on both occasions and building 5 arrow towers straight up.

Share this post


Link to post
Share on other sites

I had the same problem at a different point in the game. Same settings. Was against Dust Fiend (Lifestealer with Ankh) at level 27. I had around 650ish gold. I leaked one or two that gave gold on their second turn around the maze. Didn't build anything. Only lasted a turn.

Match ID: 2170451181

Timestamp: 24:50

Share this post


Link to post
Share on other sites

Unfortunately the match ID's aren't useful because the custom UI just breaks when spectating it, it will only load the default dota stuff. Gold is custom (so it can go over 100k) and won't show on spectator UI.

@Australian Which wave was this? All the waves or one in particular?

@Spectrus Reincarnation mobs don't give gold the first time they are killed, only the second time. Did you not receive gold the second kill (but still get the popup?)

 

Share this post


Link to post
Share on other sites
1 hour ago, Noya said:

Unfortunately the match ID's aren't useful because the custom UI just breaks when spectating it, it will only load the default dota stuff. Gold is custom (so it can go over 100k) and won't show on spectator UI.

@Australian Which wave was this? All the waves or one in particular?

@Spectrus Reincarnation mobs don't give gold the first time they are killed, only the second time. Did you not receive gold the second kill (but still get the popup?)

 

Didn't receive any gold at all until I leaked them. Got the popup.

I was able to watch the replay. I could also see my gold under net worth. Unfortunately I can't record it now cuz it seems like you've updated it ("Custom game archive doesn't match between game server and client").

Share this post


Link to post
Share on other sites
1 hour ago, Noya said:

Unfortunately the match ID's aren't useful because the custom UI just breaks when spectating it, it will only load the default dota stuff. Gold is custom (so it can go over 100k) and won't show on spectator UI.

@Australian Which wave was this? All the waves or one in particular?

@Spectrus Reincarnation mobs don't give gold the first time they are killed, only the second time. Did you not receive gold the second kill (but still get the popup?)

 

Wave 1, both times.

Share this post


Link to post
Share on other sites

This has happened to me a few times now.

Modes: Insane, Chaos, Rush.

I believe swarm and reincarnation wave's gold bounties are bugged for either the some waves. Or based on the use of certain towers at the start. (Maybe AOE?)


For reincarnation waves:
I just replicated this placing 5 arrow towers down at start. The first kill produced no gold as expected, however the second kill showed bounties but did not award the gold for the kill. I received no gold until I sold all towers, built a cannon tower, and then received bounty for only some of the kills.

EDIT: I replicated this on wave 2 with the enigma reincarnation wave. The entire wave gave 0g and should have rewarded 30.

For swarm waves:
I noticed a number of issues with this and am trying to replicate all now... it is difficult with the randomness of chaos mode. I will keep trying games to iron out details.

1) Big swarm creeps do not always split when dropping below 50% hp... if they are damaged by AOE only rather than actually being targeted by a tower. 

2) Is it possible to get a swarm wave on wave one? I imagine there would be an issue with bounty, as small creeps are supposed to give 50%, however the normal bounty already being 1g. 

I want to say I ran into this bug but have not been able to replicate it yet. (where small creeps gave no gold or big creeps gave no gold if one shot.)

Share this post


Link to post
Share on other sites

I had this bug quite a number of times on 

1) Insane, Chaos, Rush

2) Insane, Chaos, Random

3) Insane, Chaos, 

I think it occurs when i shift click to build towers quickly. During the phase where shift is held down any bounty kills are not included into the HUD or cannot be spent. The bounty still appears above the creeps dying though. 

Hopefully this helps. 

Share this post


Link to post
Share on other sites

I have had the same problem that during the ankh level you don't get bounty gold from the kills, the gold popsup but it aint getting added to your funds. And noticed that i seems like it certain lanes that have this problem, cause was playing with some friends and two of us did not get gold but the other one got it. BTW it was 4th wave

Share this post


Link to post
Share on other sites

I managed to reproduce this once on a Chaos Insane test, and then it stopped happening, still not sure what causes it.

Share this post


Link to post
Share on other sites
1 hour ago, Noya said:

I managed to reproduce this once on a Chaos Insane test, and then it stopped happening, still not sure what causes it.

Have you tried swaping lane ? i noticed like the 3rd one often have that bug

Share this post


Link to post
Share on other sites

I definitely think it has something to do with either shift queuing a lot of towers or just building towers in general. It happened to me twice in a row in a Chaos run (ankh mobs).

Share this post


Link to post
Share on other sites

Still can't reproduce it reliably guys. I will try adding the sandbox mode today so you can help me figure out what exactly is triggering it :D

Share this post


Link to post
Share on other sites

it happening with reincarnation waves (maybe with swarm as well). its a bit random though, most of the time you dont get gold from it. but sometimes you do. it might be that towards the end of the wave you receive gold more often.

Share this post


Link to post
Share on other sites

I can fix this if I find why it's happening. Questions:

1. Is it only on Chaos?

2. Is it related to shift queueing?

3. Someone managed to reproduce it on sandbox reliably?

 

Thank you for any help that can bring this bug down

Share this post


Link to post
Share on other sites

I dont play much else than chaos atm. but from what I can remember other modes are affected as well? can anyone confirm?

I dont shift queue at all though.

Share this post


Link to post
Share on other sites

On next update:

Quote

Fixed units sometimes dying from physical autoattacks, this caused units to not grant gold properly on Undead waves. 

The problem was due to the respawned units dying from physical autoattacks instead of our custom damage which should never happen. In consequence, Undead waves will be slightly harder to kill but will give all the gold as intended.

Thanks for the patience

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...