Jump to content
EleTD.com
Sign in to follow this  
Twilice

[BETA 2] Laggs?

Recommended Posts

I played with jolin012, Kingzor and Dingolicius.

And the game lagged after the first wave and the creeps had a mayor spawn delay per each creep.

They blamed it all on my internet, but this has happened before even tought I'm not the host.

But I got a little prof that It wasn't me that lagged, as soon as they lost or leaved it returned to normal (Kingzor were still there)

I had to quit so I saved the game, but I haven't played it finnished yet so heres the first part.

http://rapidshare.com/files/54077486/Re ... 1.w3g.html

(Will play the saved game soon)

Edit I could not save a replay in a saved and loaded game :cry: Blizzard bug.

Share this post


Link to post

I had similiar experiences. My worker took about 1 second to respond, when I was hosting. Is this even possible? :shock:

Share this post


Link to post
Guest emjlr3

I am going to blame Kara's GUI :)

which is why eventually i am going to upgrade most of the process heavy triggers to JASS

Share this post


Link to post
I am going to blame Kara's GUI :)

which is why eventually i am going to upgrade most of the process heavy triggers to JASS

I don't see how it can be though. I haven't really made any changes to the core GUI triggers, and we never had this problem before.

Share this post


Link to post

I had some games with hyperprimate, and we both had lag (he was host), my delay was over 1.5 seconds.

The lag apeared after some time into the game, so I assume you should check for memory leaks. :?

Share this post


Link to post

i had some minor lag when i was playing solo on bnet. worker starts moving .5 to 1 second after i clicked. it happens early and late game...

Share this post


Link to post

This is definitely a serious concern, so any information you have please do share :).

Essentially, we need to figure out the earliest that this starts appearing. Also, what circumstances does it appear in? Is it a certain tower that is causing this to happen overtime, or does it appear before any of the "special," towers enter play? If no particular tower seems to be the source, that would mean it is most likely one of the global functions that is active the entire game.

If the lag can be reproduced before any of these "special," towers enter play, that will really point us in the right direction. Either being reproduced early enough, or in a game where you don't use any of the really complex towers.

Share this post


Link to post

You can't check my replay part 1?

The creeps lagg spawn and then when they die/leave the laggs stopped.

Part2 coming today.

Share this post


Link to post

I feel like a dolt for overlooking that replay. emjlr3, when you get a chance do look it over. I am almost certain at this point that it is the DDS. This would account for several things. First, the problem is imminent before any "fancy," towers come into play. So no specific tower seems to be causing trouble here. Second, the problem is alleviated with less players (i.e. less creeps, towers) in play. Third, the problem is very apparent, the creeps never spawned like that even in full house games in 3.0, and there is no way any of my changes are causing that.

Share this post


Link to post

I could not save a replay for the part2 (blizzard bug)

But I came to level 56. (the undead illidans)

And I got my first pures.

Share this post


Link to post
Guest emjlr3

this is very convincing

it makes perfect sense that less ppl would lag less, and more more

and the fact that it did not lag at all in single player points us in the correct direction immediately

we will look into this ASAP

Share this post


Link to post
and the fact that it did not lag at all in single player points us in the correct direction immediately

I have evidence to the contrary.

http://rapidshare.com/files/54391586/Be ... r.w3g.html

The lag taking place here is clearly not network lag, as this is a single player private bnet match. Not only did an enormous gap develop between the spawning creeps (that is, the time between their spawn), but the lag was even noticeable in the hotkey presses.

Share this post


Link to post
it makes perfect sense that less ppl would lag less, and more more

Actually, i suspect the lag stops when there is only one player left in each creep team (red OR blue, teal OR purple, yellow OR orange, pink OR green). I didn't test it yet though.

Share this post


Link to post
it makes perfect sense that less ppl would lag less, and more more

Actually, i suspect the lag stops when there is only one player left in each creep team (red OR blue, teal OR purple, yellow OR orange, pink OR green). I didn't test it yet though.

there is lag even in a single-player solo game as the above posters have mentioned. it's not restricted only to multiplayer

Share this post


Link to post

hmm I have never had a lagg in solo.

But still I have only played it Not online 2 times.

But I played solo Online pretty much but no lagg for me.

Share this post


Link to post
Guest emjlr3

its not a question of online or off line, its a question of the number of players

Share this post


Link to post
Guest emjlr3

just a note, I played through the entire game, give or take a few levels, and tried many of almost every tower, with no lag to speak of in single player

Share this post


Link to post

@emjlr3 - Try to play solo, bot on b-net. Maybe then you will get the lag too.

Hyperprimate and I tried to play arrows only to see if any lag occures. We didn't get far, as the game ended in a "no more spawns after a wave after an undead wave" event. The lag was only tiny, but the spacing of the waves was slightly broken again.

Share this post


Link to post

I just played with hyper, and we had like several seconds lag at the worst times.

Mech levels gave a strong lag boost, like up 2 secs from 1 sec lag.

And for some reason the wave 60 (not ronald, the healing evil childs) were more or less lag free all of a sudden.

We seemed to have an "overall backgroud lag" of about .5 second for most of the game, that started early (gotta check when), and that build up with towers and especially aforementioned mech waves. (Extra mech lag was gone after the wave was over.)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...