Jump to content

[SC2] Element TD 1.48

Recommended Posts


-XP fixes for the Insane difficulty

-Tweaked Extreme Mode to 50 lives, wave timer after spawning, short timer durations

-Nerfed mineral bonus for Pure Essence selection

-Added a mineral bonus for Pure Essence selection (Wars)

-Buffed Pulverize (Hero) to 6 AoE from 4.5

-Fixed accuracy of Ice Tower (LW) range indicator

-Added a range indicator to the Hero unit

-Renamed Helix (LW) to Blizzard

-Renamed Magic Attack (DFL) to Magic Barrage

-Tweaked Cast Lightning (FL) to lose damage per bounce instead of gain

-Buffed Hail Tower (DLW) to 420 base DPS from 387

-Buffed Evaporate (FW) secondary damage to match primary

-Buffed Torrent Tower (LNW) base attack to 140 damage from 100

-Buffed Ice Tower (LW) to 50 DPS from 44

-Buffed Runic Tower (DFL) to 272 DPS from 181

-Nerfed Magic Barrage (DFL) extra attacks to half damage

-Fixed creeps not spawning when partner leaves under certain situations (Teams)

-Support Towers now spawn creeps as well (Wars)

-Gave Celerity Tower (FNW) a minimum range of 7

Share this post

Link to post

Kay, gave Insane + Extreme a shot... it's impossible... by a long shot. Primary reason? You literally don't have the money to build the towers. Haven't tried Extreme + Very Hard yet, but I'm just gonna say this now - buff the income by 20-25%, including the starting gold. It's that bad. And increase the amount of time between waves per 5 waves by 15 seconds.

I got to the 30s and then just disintegrated, literally nothing I could do.

EDIT: Alright, got a build that worked pretty well for Very Hard, trying it for Extreme now.

Share this post

Link to post

There is no link, it's for StarCraft 2, you can search for it in the arcade.

I've tried launching the map multiple times in the arcade but it doesn't work, it starts at black screen, the "created by" message types out, then sc2 crashes. Happens for my friend too. Is this happening to anyone else? Is this map still supported? Note we're both on the Starter Edition.

Share this post

Link to post

There was a recent patch to SC2, and I know it was working fine before that. I loaded the map up just now on the latest SC2 version, and it's working fine. It's probably some error with the Starter Edition, dunno why that'd be the case though. As far as I know, development on the map was halted for a while, but I believe it's starting back up as of recently. Hopefully this issue will get ironed out soon.

Is this the only map that doesn't work, or are there others?

Share this post

Link to post

It eventually started to work, tested the hell out of it to see what it could be. I don't understand why, but it appears to only crash when Silverlight is running in chrome before launching SC2. If I do other maps it works fine, if I launch Silverlight (Netflix) after SC2 is launched it is fine, but if I have Netflix open then launch SC2 and start up EleTD, game crashes. I only tested this in Chrome (latest stable branch).

Hope that helps, as strange as the cause sounds. I might try it again in a bit to see if that's REALLY causing it or just a couple coincidences. Glad I got it working though, first time I've been able to play EleTD since my WC3 broke.

Share this post

Link to post

  • Create New...